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[bookmark: _Toc497389671]Basic

[bookmark: _Toc497389672]Prerequisites
· FMS 1011-FMS Financial Data Architecture for Financial Users
· FMS 1100 - Accessing Essential Financial Information

[bookmark: _Toc497389673]Open BI Portal, BI Help Pages & Knowledge Base

[bookmark: _Toc497389674]Berkeley Lab BI Portal
To access the Berkeley Lab BI Portal, go to the lab homepage, lbl.gov, A-Z index, F, and click on Financial Reporting (Cognos) (FY15+) *.  You can also input http://cogweb.lbl.gov/cognos into your browser.

[bookmark: _Toc497389675]Help
To access the Berkeley Lab BI Portal Help Pages, click on the help link in the BI Portal landing page or the Help Tab:
[image: ]


[bookmark: _Toc497389676]FMS Knowledge Base
To access the FMS Knowledge Base, go to the lab homepage, lbl.gov, A-Z index, F, and click on Financial Management System (FMS) Help & Knowledge Base.  You can also input http://fms-knowledge.lbl.gov/ into your browser.  This site has help for many financial systems including the BI Portal as well as a link to open a help ticket if necessary:
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[bookmark: _Toc497389677]Run Institutional Delivered Reports
The landing page of the Berkeley Lab BI Portal is the Reports tab which contains pre-built, institutional reports organized by subject area.  Click on the links and answer the prompts to run these reports:
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[bookmark: _Toc497389678]Schedule Institutional Delivered Reports
Since institutional reports are for lab wide use, they are write protected.  In order to schedule these reports, one must first create a report view and set the filters.  Steps are as follows:
Step 1
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Step 2
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Step 3
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Step 4
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Step 5
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[bookmark: _Toc497389679]Self Service Reporting
Users can create their own custom reports by clicking on the links in the Berkeley Lab BI Portal Self Service tab which launch the authoring tool “Query Studio”:
[image: ]
Data is organized by “Packages” which are subsets of data from the Lab’s many IT systems organized by functional area.  Functional areas include Divisional (summarized costs plus funding), Cost Detail, Planning, Spend Plan Actuals, Procurement Summary, Procurement Details and eSRA (pre-award).
“Templates” are starter reports that you can open and modify based on your needs.  In the Berkeley Lab BI Portal > Help > Self Service Divisional Templates you will find a list of all templates plus sample output.
However, if you want to create a custom report from scratch, you can click on a Query Studio Package link and build a report.


[bookmark: _Toc497389680]Reports & Data Dictionaries
On the Berkeley Lab BI Portal > Help > Definitions and Descriptions, you will find links to the data dictionaries and source data descriptions.
· Cognos Delivered Reports & Self Service Packages contains information about the institutional reports’ and self service packages’ purpose plus source data
· Self Service Packages Data Dictionaries contain a matrix of all fields available in the BI Portal and which Packages they are associated with
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[bookmark: _Toc497389681]Query Studio
[bookmark: _Toc497389682]Launch & Navigate Query Studio
You can launch Query Studio, the self service report authoring tool, by going to the Berkeley Lab BI Portal > Self Service and clicking on a template link or a query studio package link.
The Query Studio User Manual is located at the Berkeley Lab BI Portal > Help > How To Use The Tools > Cognos User Manuals > Cognos Query Studio.
The Query Studio user interface and icons are intuitive and similar to commonly used business software:
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[bookmark: _Toc497389683]Package Definitions and Descriptions
A complete, updated list of all package links is located on the Berkeley Lab BI Portal > Help > Definitions and Descriptions > Cognos Delivered Reports & Self Service Packages.  The main packages are as follows:
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[bookmark: _Toc497389684]Open, Modify & Save Existing Templates

Templates are starter reports that you can open and modify based on your needs.  They are located at the Berkeley Lab BI Portal > Self Service and are organized by Package (functional area):

[image: ]
Open: Click on the link
Modify: Templates with the Query Studio Icon (a pen) to the left will launch in the authoring tool which you can use to modify the report. In addition to the directions above for Create a Basic Layout, the Berkeley Lab BI Portal > Help > How To Use The Tools contains a number of tutorials on how to modify reports.
Save: Click on the save as icon and navigate to the directory where you want it to be saved.  My Folder is your personal folder that no one else has access to.  Divisional Folders are visible to everyone at the lab who has a username and login and can be found in Cognos > Public Folders.


[bookmark: _Toc497389685]Add and Change Report Title

1. From the Change Layout menu, click Edit Title Area. (Tip: To change the title without going through the menu, click the Title link.)
2. In the Title box, type a new title.
3. If you want filters defined in the report to appear in the title area, select the Show filters check box.
4. If you want sorting defined in the report to appear in the title area, select the Show sorts check box.
5. If you want suppression defined in the report to appear in the title area, select the Show suppression check box.
6. Click OK.
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[bookmark: _Toc497389686]Add, Delete and Move Fields

[image: ]
Add Field: Select Insert Data from the menu on the left, select the field you want to insert, highlight the field in the report where you want this field to get inserted, then click Insert
Delete Field: Highlight the field in the report you want to delete then click the X icon on the toolbar
Move Fields: Highlight the field in the report you want to move, click the scissors icon (cut) then highlight where you would like this field to get pasted, then click the clipboard icon (paste) on the toolbar.


[bookmark: _Toc497389687]Add and Change Filters

1. Click the heading of the column.
2. Click the filter button [image: ] on the toolbar.
3. Choose the items you want from the pick list or Search For Values.  Please note that the pick list is limited to 1,000 entries so large fields like Purchase Order Number exceed this amount so you will need to use Search For Values for those large fields
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[bookmark: _Toc497389688]Sort Data

You can organize the data in a report by specifying a sort order. Data can be organized in ascending or descending sort order based on the values in any data item.   Highlight the field you want to sort by then click the sort icon.

[image: ]



[bookmark: _Toc497389689]Suppression
Sparse or zero value data can result in crosstabs showing rows of empty or zero value cells. For example, the Divisional Summary crosstab without suppression may result in many rows of all empty or 0 value measures for old, closed projects.  You can suppress rows, columns, or rows and columns based on zero, null, divide by zero, and overflow values. Suppressing rows and columns with no data gives you a more concise view of your report.
Click on the suppression icon in the tool bar and choose the suppression methods that best fits your needs:
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[bookmark: _Toc497389690]Output to Excel, PDF, etc. and Change Output Type
From the Run Report menu, click on the output format you want:
[image: ]
When you save your report, the default action is to run to HTML.  You can override this default by clicking on the Set Properties icon in the folder you saved it:
[image: ]
Then select the Query tab and Override the default values:
[image: ]
[bookmark: _Toc497389691]Save Report

Click on the save as icon and navigate to the directory where you want it to be saved.  My Folder is your personal folder that no one else has access to and is the default.  Divisional Folders are visible to everyone at the lab who has a username and login and can be found in Cognos > Public Folders.
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[bookmark: _Toc497389692]Create a Basic Layout and Save using Query Studio Package Link
Clicking on the Query Studio Package link will launch the Query Studio authoring tool and allow you to create a report from scratch:
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[bookmark: _Toc497389693]Insert Fields

After you click on the Query Studio package link, the Query Studio report authoring tool will launch.  To add a field, select Insert Data from the menu on the left, select the field you want to insert then click Insert.
Since the data warehouse includes multiple financial years data, we recommend you first insert the Fiscal Year field and always include a measure such as Full Cost Amount.
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[bookmark: _Toc497389694]Filter, Sort, Add Suppression, Title, Save

After you have added your required fields, then add filters, sort, suppress, title and save as shown in the above “Open, Modify & Save” section.
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[bookmark: _Toc497389695]Intermediate

[bookmark: _Toc497389696]Prerequisites
· USER GUIDE - BERKELEY LAB BI PORTAL: Basic Section
· FMS 1011-FMS Financial Data Architecture for Financial Users
· FMS 1100 - Accessing Essential Financial Information
· FMS 1102 - Accessing Essential Financial Information

[bookmark: _Toc497389697]Query Studio
[bookmark: _Toc497389698]Rename Column Headings
Open a report in IBM Cognos Query Studio.  Double-click the heading of the report item that you want to rename.  In the Name box, type a new name.  Click OK.
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[bookmark: _Toc497389699]Summarize
Query Studio also automatically generates footer summaries for measures. For example, if you add the report items Project and Full Cost Amount to a report, you get an overall total for Full Cost Amount at the bottom of the report.
Use the Summarize command to add or remove footer values, or to change how detail values are calculated. For example, use the Summarize command to place an average in each footer.
1. Open a report in Query Studio. 
2. Click the heading of the report item you want to summarize. 
3. From the Edit Data menu, click Summarize.
4. In the Summary for footers box, click the function you want.  If you want to apply one summary calculation to the detail values and a different summary calculation to the footer values, or you want to change the default order of operations in a calculated column, click the Advanced link.
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[bookmark: _Toc497389700]Formatting
You can format a report to give it the look you want.  For example, you can change the font and font color, as well as specify effects, such as strikethrough. You can format the following: titles and subtitles; filter text; sections; column headings; data; group, section, and overall summary titles and values.
[bookmark: _Toc497389701]Change Font Syles
· Open a report in IBM Cognos Query Studio.
· If you want to format text for a particular object, such as a specific column or a column heading, click the object. (Tip: Press Ctrl+click or Shift+click to select multiple objects.)
· From the Change Layout menu, click Change Font Styles. (Tip: You can also use the style toolbar to quickly format an object.
· For example, you can use the toolbar to change the font, the font size, the font color, or the background color.)  Specify the options you want to apply.
· If you want to specify the font color, click the font color button, and choose how you want to select the color.  Click OK.
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[bookmark: _Toc497389702]Formatting Data
· Open a report in Query Studio.  Click the heading of the report item you want to format.
· From the Edit Data menu, click Format Data and then click one of the following: To format numeric data, in the Category box, click a type and define the format as required.
· To format text data, in the Category box, click Text and type a number in the Number of visible characters box.
· To format date and time data, in the Category box, click a type and then in the Type box, click a format.  
· Click OK.
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[bookmark: _Toc497389703]Defining Conditional Styles
You can define conditional styles to highlight key information in a report.  You can use conditional styles with numeric data, text data, and date values. For example, use conditional styles to highlight all balances greater than five million in green and all balances less than one million in red.
· Open a report in IBM Cognos Query Studio.
· Click the report item for which you want to define conditional styles.
· From the Change Layout menu, click Define Conditional Styles.
· Insert value ranges, set style, then click OK.
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[bookmark: _Toc497389704]Change Page Size
[bookmark: _Toc497389705]PDF
Before you begin: You must have Adobe Acrobat Reader installed on your computer to view a report in PDF format.
· Open a report in IBM Cognos Query Studio.
· From the Run Report menu, click View in PDF Format .  The report opens in PDF format in a new window.
· To specify the orientation and page size of your PDF report, from the Run Report menu, click Specify PDF Options.
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[bookmark: _Toc497389706]HTML
You can specify the maximum number of rows of data to appear on the page.  By default, IBM Cognos Query Studio shows 20 rows of data. The more rows that are retrieved, the more time that is needed to retrieve data. You can improve performance by showing fewer rows.
By specifying the rows per page to a higher number, you can scroll up or down the report, eliminating the need to repeatedly page up and page down.
· Open a report in Query Studio.
· From the Change Layout menu, click Set Web Page Size.
· In the Number of Rows box, specify the maximum number of rows you want to appear on a page.  Tip: To see row numbers in your report, click the Show row numbers check box. 
· Click OK.
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[bookmark: _Toc497389707]Calculations
You can perform calculations in a report using data from one or more report items.  For example, you can subtract Full Cost Amount from Available Funds to derive Uncosted Balance. You can also concatenate first names and last names into a single column.  Please note that you cannot edit a calculation. Instead, you must delete the calculated report item and recalculate it.  You can see the syntax of the calculation in the Expression box of the Calculate dialog box. You can also see the expression used in a calculation by viewing the report definition.
· Open a report in Query Studio.
· Click the headings of the report items you want to include in the calculation.
· Click the calculate button on the toolbar.  In the Operation box, click the type of operation you want to perform.  Depending on the selected data, you may first need to choose an operation type from the Operation type box.
· Choose which data to use for the calculation: To use the data in existing report items, in the Selected report items box, click the report items you want. To use other data, in the Number box, specify a number.
· Depending on the calculation you choose, you may see additional options, such as changing the order of the operands, typing in a number, or choosing a grouping level.
· Click Insert.  The calculated results appear in a new column. By default, the expression used in the calculation is used as the heading name.
· To make the name of the calculated column more meaningful, type a new name in the New item name box.[image: ]

[bookmark: _Toc497389708]Schedule Self Service Reports
You can schedule your Self Service Reports to run at a time that is convenient for you.  For example, you may want to run reports or agents during off hours when demands on the system are low. Or you may want to run them at a regular weekly or monthly interval.
In the Berkeley Lab BI Portal, click the schedule button for the entry you want to schedule. 
[image: ]
Under Frequency, select how often you want the schedule to run. The Frequency section is dynamic and changes with your selection. Wait until the page is updated before selecting the frequency.
Under Start, select the date when you want the schedule to start.
Under End, select when you want the schedule to end.  If additional options are available on the Schedule page, specify what you want.  For example, for reports, you can select formats, languages, delivery method (including how to save report output files), and prompt values.
Click OK.
[image: ]
[bookmark: _Toc497389709]Advanced
[bookmark: _Toc497389710]Prerequisites
· USER GUIDE - BERKELEY LAB BI PORTAL: Basic Section
· USER GUIDE - BERKELEY LAB BI PORTAL: Intermediate Section
· FMS 1011-FMS Financial Data Architecture for Financial Users
· FMS 1100 - Accessing Essential Financial Information
· FMS 1102 - Accessing Essential Financial Information
· Financial Reporting Series Class Recordings & Slides
[bookmark: _Toc497389711]Query Studio
[bookmark: _Toc497389712]Complex Filters
You can combine two or more filters to do more complex filtering. For example, you want to filter the columns Project ID or Division for a Fiscal Year in a report.
· Open a report in IBM Cognos Query Studio.
· From the Edit Data menu, click Combine Filters.  If the filters you want to combine do not yet exist, click Add a filter line and create them.
· Press Shift+click or Ctrl+click to select the select line icon of the filters you want to combine.  Click Group.  Tip: You can modify a filter line by clicking its link.
· Click the operator that appears between the filters and click AND or OR to combine them.
· If you want to convert a filter line or a combined filter into a NOT filter, click the filter line or combined filter and click Apply NOT.  Tip: If NOT has already been applied to a filter line or combined filter and you click Apply NOT, the NOT operator will remain. If you want to remove NOT, click Remove NOT.
· Click OK.
[image: ]
[bookmark: _Toc497389713]Crosstabs
A crosstab report shows a measure at the intersection of each row and column.  This is useful for showing more information in a smaller area. For example, if a report shows Months as columns, Project as rows, and Full Cost Amount as the measure, the value at the intersection of each column and row shows the Full Cost Amount for that Project ID by Month.
· Open a report in Query Studio.
· Click the heading of the report item you want to use as the top row.
· Click the pivot button on the toolbar.  The values of the selected report item are now column headings. The other report items become row headings, and the measure is now at the intersection of the two.  Tip: To change the crosstab report back to a list report, click the top row, and then click the ungroup button on the toolbar.
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[bookmark: _Toc497389714]Grouping
A simple list report that contains columns of unique values is easy to understand.  However, after you add more columns, you may find that duplicate values appear in your report.  Grouping a report sorts the data and suppresses duplicate values in the grouped column. For example, a report contains information about the Full Cost Amount, in columns named Project ID and Activity ID. Each Project ID has more than one Activity ID, so the same Project ID value appears in multiple rows in the Project ID column.  You group by Project ID to suppress duplicate values of the Project ID report item, sort the Project IDs, plus generate footer summaries for each Project ID.
· Click the heading of the Project ID column.
· Click the group button on the toolbar.  The values in the Product lD column are sorted numerically (alphabetically), and duplicate values are removed.  You can also click the ungroup button on the toolbar to ungroup a report.
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[bookmark: _Toc497389715]Expand/Collapse a Group
You can view only the details you want by expanding and collapsing a report. Collapsing a report temporarily removes progressive levels of detail, making it easier to find and compare high-level summaries. Expanding a report restores the collapsed levels.  You can expand and collapse only those reports that contain a measure.  You cannot collapse reports that contain custom groups.  Note: There is no visible indication that a report is collapsed. For example, you  collapse a report, and then save it. Another person can open the report later and  not be aware that the report is collapsed.
· Open a report in IBM Cognos Query Studio.
· Click the collapse group button on the toolbar.  Repeat until you are at the required level of detail.  Tip: To expand a collapsed report, click the expand group button on the toolbar.
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[bookmark: _Toc497389716]Custom Grouping
Create custom groups to produce a new report item containing values that are meaningful to you.  Use custom groups to convert a list of numeric results into broader categories.  For example, break down sales results into Low, Medium, and High.  Or reduce the number of values into a smaller, more meaningful set.  For example, change a list of employees into My Team and Others.  You cannot collapse a report that contains custom groups.
· Open a report in IBM Cognos Query Studio.
· Click the heading of the report item for which you want to create a custom group.  Tip: You can also click a column value.  From the Edit Data menu, click Define Custom Groups.
· In Customization type, choose how to define the values:  To create a group of values based on individual items, click Individual values.  Note: This option is not available if the report item is numeric, such as Full Cost.  In the New group name box, type a name, and click the down arrow link to add it to the Custom groups box.
· In the Available values box, click the  values you want, and click the left arrow link to add them to the Custom group values box.
· To create a group of values by defining a range, click Ranges.
· In the New range name box, type a name.
· In the From and To boxes, specify  the criteria you want, and click the arrow link to add to the Ranges (in sequential order) box.
· In the New item name box, type a name for your report item.  Click All remaining values (including future values) and decide how remaining and future values are handled:  If you want the group name for remaining values to match each value, click Use the individual values as range names.
For example, the group name produced for the margin value 0.411 would be 0.411.  If you do not want a group name to appear for remaining values, click Do not show range names. Clicking this option will produce empty cells in the new report item for remaining values.  If you want to specify your own group name for all remaining values, click New range name and type the name you want.
Click OK.
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[bookmark: _Toc497389717]Sections
Creating sections shows the value of a selected report item as the heading of a section.  Open a report in IBM Cognos Query Studio.
· Click the heading of the report item by which you want to group.
· To create sections, click the create sections button on the toolbar.
· To remove sections, click the original item heading or section heading and then click the ungroup button on the toolbar.
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[bookmark: _Toc497389718]Report Definition
The report definition describes the report items in each report and gives users, administrators, and customer support an important troubleshooting tool.
· Open a report in IBM Cognos Query Studio.
· From the Manage File menu, click Report Definition. The Report Definition dialog box appears. It contains a table that lists every filter, report item, and corresponding expression in the report.  Note: You cannot change the report properties.
· To display a text box containing information about the query that you can send to customer support for troubleshooting if needed, click Query Information.
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[bookmark: _Toc497389719]Rollup Report
A rollup report is an aggregation of child amounts to a control point.  Rollup capability is available in the Cost Detail and Divisional Packages.  You can create rollup reports by work breakdown structure (WBS) or Project – Activity levels.
Before creating your rollup reports, please first review the Project Information Report in the Berkeley Lab BI Portal > Reports > Dashboards as well as the Project Activities screen in Financial Management System (FMS 9.2 – FY15+) > Project Costing > Activity Definitions > Project Activities to get a good understanding of your WBS and Activity hierarchies.
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[bookmark: _Toc497389720]Work Breakdown Structure (WBS) Rollups


[image: ]


Step 1
Add WBS Levels to your report in correct order:
[image: ]


Step 2
Highlight the project then press the group icon, then highlight each of the WBS levels and press the group icon until the subtotals are at the correct level.
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[bookmark: _Toc497389721]Project Activity Level Rollups

There are two methods to create a project activity level rollup report.  You can use the grouping method similar to the WBS method above or you can output an ungrouped report to excel then use excel’s pivot function.

Excel Pivot Method
Create a list report, add Activity Level ID/Description fields plus Activity ID (this is where costs are collected in Peoplesoft), then pivot on the level that you want your report.
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Query Studio Grouped Method
This is similar to the WBS grouped report method above.  Create a list report with Level Activity ID and Level Activity Description then use the concatenate function to combine ID and Description, then group:
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Project Activity Level Rollup Report output will look like this:
[image: ]


[bookmark: _Toc497389722]Charts
Use charts to present information graphically and to see patterns and trends in data. For example, you can see how planned costs compare to actual costs, or whether costs are falling or rising year over year.
You can show just the chart, or the chart with the table appearing under the chart.
1. Open a report in Query Studio.  Reorder report items, if necessary.
2. Click the chart button on the toolbar. In the Chart type box, click a chart style.
3. Click a chart configuration.  If you want to view only the chart, click Chart only.  If you want the values to appear on the chart, select the Show the values on the chart check box.
4. Click OK.
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